KCF SMARTdiagnostics Upgrade Open Issues
Incident Report for KCF Technologies
Resolved
A Hotfix has been deployed to address problems for loading custom and default indicator filters for our Oil & Gas customers.

For customers who accessed custom PowerBI dashboards through our external site, that site unexpectedly stopped working today. We are still investigating that issue but in the meantime, if you log into the Dashboards module within SD4, all custom PowerBI Dashboards are available to you that were previously housed on the other site. You can update your bookmarks to the new SD4 Dashboards or use the Star icon to 'favorite' these dashboards and make them more quickly available through your Favorites links within the application.

At this time, all critical issues related to this release have been fixed. We are going to officially close this incident but if you have any other issues, please contact our TPC Team or your Sentry Representative.

Thank you again for your patience during this upgrade and we hope you enjoy the new SMARTdiagnostics software!
Posted May 23, 2022 - 17:05 EDT
Update
Hotfixes were deployed this morning to address the following problems:

OPC data is once again being received. This issue has been resolved.

The Alerts screen in SD3 is displaying all Alerts once again. This issue has been resolved.

The Reset Password functionality has been fixed, which should address most issues users had with recovering forgotten passwords. If you are still having trouble logging in, please contact our TPC team and we will investigate other potential root causes.

In addition to those updates, we are currently working on another Hotfix that will address issues loading customer and default indicator filters in SD4, specifically impacting our Oil & Gas customers. We will provide an update on that Hotfix status as we make progress.

Thank you for your continued patience!
Posted May 23, 2022 - 12:50 EDT
Identified
KCF engineers are investigating several open items related to our major release this morning.

OPC data is flowing into SMARTdiagnostics, however KCF is having trouble receiving it on our end. The team is actively investigating this issue.

A Hotfix is going out very soon to address an issue with the Alerts screen not populating in SMARTdiagnostics 3. If you are attempting to acknowledge Alerts generated from subscriptions in SD3, you will likely see a blank screen. Alert acknowledgements are working in the new SMARTdiagnostics 4 if you navigate to the Asset and acknowledge from there.

Reset passwords for forgotten logins are throwing errors. The team is investigating these errors. If you are having trouble logging in, please contact TPC.

We will provide updates as we make progress on these issues.
Posted May 23, 2022 - 07:09 EDT
This incident affected: SMARTdiagnostics and SMARTdiagnostics OPC Connectors.