KCF Academy - Unplanned Service Outage
Incident Report for KCF Technologies
Resolved
This incident has been resolved.
Posted Jan 21, 2022 - 12:24 EST
Update
The issue has been resolved and KCF Academy is once again accessible to users. Thank you for your patience and we look forward to your continued learning experience!
Posted Jan 21, 2022 - 12:23 EST
Investigating
KCF Academy is currently inaccessible to users due to an unexpected change by our vendor. We apologize for the inconvenience and will keep you updated once it is available again.
Posted Jan 21, 2022 - 08:31 EST
This incident affected: KCF Academy.